Serveranforderungen für die JFeWo Ferienhaussoftware

JFeWo wurde entwickelt, um auf Standard Webhosting Servern problemlos zu funktionieren. Je besser Ihr Server ausgestattet ist, umso mehr profitiert JFeWo davon.

Joomla Version

JFeWo benötigt mindestens Joomla 3.4

PHP Anforderungen

  • PHP Version 5.6 oder 7.0

MySQL

  • Mindestens 5.1

Notwendige PHP Erweiterungen

  • GD Bibliothek (alle Pakete)
  • IonCube Loader (alle Pakete)
  • JSON (alle Pakete)
  • SimpleXML (ab Agency Paket)
  • dom (ab Agency Paket)
  • libxml (ab Agency Paket)
  • xmlreader (ab Agency Paket)
  • xmlwriter (ab Agency Paket)
  • zip (ab Agency Paket)
  • fileinfo (nur Portal Paket)

Der JFeWo Check

Sollten Sie sich unsicher sein, ob JFeWo grundsätzlich auf Ihrem Server läuft, können Sie die JFeWo-Check PHP Datei herunterladen, um dies zu prüfen.

  1. JFeWo Check herunterladen
  2. Die Datei check.php auf Ihren Server kopieren
  3. Die Datei wie folgt aufrufen: www.company.com/check.php

Beachten Sie, dass Joomla in zwei Instanzen läuft. Ein Mal im Frontend und Ein Mal im Backend. Sie sollten sicherheitshalber beide Verzeichnisse testen. Kopieren Sie die Check-Datei also auch auf www.company.com/administrator/check.php und rufen Sie sie auf.

Sollte eine der Anforderungen rot aufleuchten, dann müssen die entsprechenden Servereinstellungen geändert werden.
In der Regel ist jeder Serveranbieter/Hoster dazu bereit, die nötige Bibliothek auf den neuesten Stand zu bringen oder nachzurüsten.

IonCube Encoder

Die IonCube Encoder ist eine für den Betrieb unserer Produkte nötig Erweiterung. Jeder Hoster bietet diese Erweiterung an. Sie muss häufig nur aktiviert werden.

Beispiel des Hosters DomainFactory (DF)

DF ermöglicht die Aktivierung der IonCube Erweiterung auf zwei Wegen. Entweder über den PHP.INI-Editor von DF oder über eine selbst angelegte php.ini Datei. Wir empfehlen den PHP.INI-Editor zu nutzen.

Wichtig ist, dass Sie die passende Erweiterung für die PHP-Version Ihres Servers wählen.

Anleitung von DF
https://www.df.eu/de/service/df-faq/webhosting/skriptsprachen/phpini-editor/#acc8523

Bei DF können Sie auch php.ini Dateien in Ihr Hauptverzeichnis legen. Folgende zwei Zeilen sind dabei beispielhaft für PHP 5.6 nötig:

zend_optimizer.enable_loader=1
zend_extension="/usr/local/lib/php_modules/5-56STABLE/ioncube_loader_lin_5.6.so"

Ist der IonCube Encoder aktiviert worden, sollten Sie einen Eintrag wie den folgenden in Ihren Systemeinstellungen sehen:

Ioncube Encoder ist aktiv

Ihre Systemeinstellungen erreichen Sie wie bei Joomla üblich über:
http://www.meineseite.de/administrator/index.php?option=com_admin&view=sysinfo

5 mos ago